Mac OS X v10.7 "Lion" Compatibility

The following software versions are compatible with Mac OS X 10.7 "Lion":

  • Synk 7.0.11 and later
  • DTerm 1.6 and later
  • Screen Mimic: A bug in Lion makes Screen Mimic nonfunctional under that OS. We've reported the issue to Apple, and have an updated version of Screen Mimic we will release once they have fixed the bug.

The following software versions are compatible with Mac OS X 10.6 "Snow Leopard":

  • Synk 6.5 and later
  • DTerm 1.2 and later
  • Screen Mimic 2.4.3 and later

Comments? Suggestions? Can’t find the answer you need?

Email us at and we’ll be happy to help!